5ain7 ga11 . CH || i7-l3ak5. CH || g07r007.CH

Hardware

Sonicwall NAT Loopback Policy

by on Mar.30, 2015, under Firewalls, Knowledgebase, Kommunikation, Networking

 

NATLoopback

 

Original Source: LAN Subnets
Translated Source: WAN Primary IP
Original Destination: (WAN server object)
Translated Destination: (LAN server object)
Original Service: Any
Translated Service: Original
Inbound Interface: LAN Interface
Outbound Interface: Any

Leave a Comment more...

Resetting Cisco Catalyst 29XX to factory settings

by on Feb.26, 2015, under Cisco, Knowledgebase, Kommunikation, Networking, Switches

Grundkonfig löschen:

Cat2950# delete flash:vlan.dat
Delete filename [vlan.dat]?

!— Press Enter.

Delete flash:vlan.dat? [confirm]y

Cat2950# reload
Proceed with reload? [confirm]y
4w5d: %SYS-5-RELOAD: Reload requested

VLAN DB löschen:

Cat2950# delete flash:vlan.dat
Delete filename [vlan.dat]?

!— Press Enter.

Delete flash:vlan.dat? [confirm]y

Cat2950# reload
Proceed with reload? [confirm]y
4w5d: %SYS-5-RELOAD: Reload requested

Leave a Comment more...

nice2know: SMTP Responde Codes

by on Jul.02, 2014, under Exchange 2007, Exchange 2010, Exchange 2013, Exchange Server, Knowledgebase, Kommunikation, Server-Plattformen

SMTP ERROR CODES

Here are the most common codes:

2xx Request ok. Go ahead.

220 Mail service is running (ESMTP ready).

221 2.0.0 Closing connection (Mail received successfully, Goodbye).

250 2.0.0 Message accepted for delivery

250 2.1.0 Sender e-mail address ok.

250 2.1.5 Recipient e-mail address ok.

3xx Request ok, but more input is needed to complete the action successfully.

354 Enter mail, end with CRLF.CRLF

4xx Temporary error, try again.

421 4.2.1 The service is not available and the connection will be closed.

441 4.4.1 Cannot connect to remote host (host has DNS entry, but can’t be connected to).

450 4.5.0 Mailbox temporarily unavailable.

451 4.1.8 Sender e-mail address domain does not resolve temporarily.

451 4.7.1 Greylisting in action, please come back later.

454 4.7.0 TLS not available due to local problem. Please try again later.

5xx Permanent error. Don’t try again.

500 5.5.1 Syntax error, command unrecognized.

503 5.5.0 Sender e-mail address already specified.

503 5.5.1 Need MAIL before RCPT.

544 5.4.4 Host not found (not in DNS).

550 5.1.1 Mailbox does not exist.

550 5.1.3 Bad e-mail address syntax.

550 5.7.0 Your IP address is in a blacklist.

553 5.1.8 Sender e-mail address domain does not exist.

554 5.7.1 Relaying denied

Leave a Comment more...

PERC 5 Controller und RAID 0 mit Disk Missing

by on Oct.23, 2013, under Dell, Knowledgebase, PERC Raid Controller

 

Ich hatte den Challenge bei einem Dell PowerEdge 2950 mit einem PERC5 Raid Controller mich um ein defektes RAID O zu kümmern. Das Striping war über 3 Platten verteilt. Beim Slot 3 der dritten Platte hiess es: Disk Missing.

Mit diversen Tests konnte ich jedoch herausfinden, dass die Disk i.O ist und der Controller ein Problem mit dem Slot haben muss.

Ich musste das RAIDO löschen und neu erstellen OHNE die Option “Initialisieren” zu aktivieren (wichtig: darf nicht aktiv sein!!). Das RAID 0 wurde neu gebildet und die Daten waren wieder da….heureka!!

 

Leave a Comment more...

Inter-VLAN Trunking zwischen einem Cisco 3750 und HP ProCurve 2910al

by on May.16, 2013, under Cisco, H3c Switches, Hardware, Kommunikation, Networking, ProCurve, Router, Switches

Ich stand von der Aufgabe, einen Layer 3 HP ProCurve 2910al mit einem Cisco 3750 (ebenfalls Layer 3) Switch mittels VLAN-Trunking zu koppeln. Da der Cisco Switch nur noch als “ACCESS-Switch gebraucht wurde” musste ich ihn zuerst mit

<no ip Routing> zu einem Layer 2 Switch degradieren.

Der DOT1Q Trunk war schnell erstellt und die Kommunikation der VLANs untereinander funktionierte fast einwandfrei. Das einzige Problem war, dass die MGMT IPs im VLAN1 einander nicht pingen konnten.

 

ProCurvenormal

ProCurvenormal

Bei einem HP ProCurve Switch sieht ein Trunk Port normalerweise so aus:

In diesem Fall hängt am Port 3 und Port 6 ein weiterer HP ProCurve Switch. Die Kommunikation der nativen MGMT IPs funktioniert in diesem Fall, da der am anderen Ende des Trunk stehende Switch ebenfalls das native VLAN1 hat.

Wenn jedoch am anderen Ende des Schlauches ein Cisco Switch steht, der zwar ebenfalls das VLAN1 als natives VLAN hat, dann funktioniert zwar die Inter-VLAN Kommunikation, aber die MGMT IPs sehen einander nicht….komisch eigentlich…den

<sh cdp neighbors> auf dem HP Switch gibt folgenden Output:

cdp

Der gleiche Befehl auf dem Cisco Switch zeigt keinen Partner an.

Die Lösung lag wie immer in einem kleinen Detail. Der Uplink Port durfte auf dem MGMT VLAN nicht TAGGED sein, sondern UNTAGGED. 1 Klick und die Kommunikation war gewährleistet. Die restlichen VLANs, welche über den Port weitergegeben werden sollen müssen auf TAGGED belassen werden.

untagged

untagged

 

Sample Konfig HP ProCurve (Port 6 ist Trunk Port):

vlan 1
name “Netzwerk-Komponenten”
untagged 6 (uplink port)
ip address x.x.x.x x.x.x.x
exit
vlan XXX
name “TESTVLAN”
ip address x.x.x.x x.x.x.x
tagged 6

Sample Konfig Cisco (Port Gig1/0/2 ist Trunk Port):

interface GigabitEthernet1/0/2
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
mls qos trust dscp
spanning-tree portfast trunk

interface Vlan1
description Netzwerk-Komponenten
ip address x.x.x.x x.x.x.x
no ip route-cache
!

 

und so klappts auch mit dem Nachbar!!

 

 

Leave a Comment more...

simpler ScriptBackp von ProCurve Switches

by on Apr.11, 2013, under Hardware, HP, Knowledgebase, Networking, ProCurve, Switches

Hier eine simple Variante um Backups von HP ProCurve Switches via Script zu erstellen. Dazu braucht es das Tool pscp von Putty.

http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html

<pscp -scp -l USERNAME -pw PASSWORD -2 192.168.1.10:cfg/running-config d:\switch.cfg>

Allenfalls muss noch der ssh file Transfer auf dem Switch aktiviert werden.

<conf t>

<ip ssh filetransfer>

 

 

Leave a Comment more...

XEN Server crashen randomly mit Proliant DL 380 G6

by on Feb.29, 2012, under Citrix, Hardware, HP, Knowledgebase, Proliant DL 380, XEN-Server

Ich hatte neulich das Problem, dass sich diverse XEN Server in einem Pool in einer wilden Kombination verabschiedet haben (Reboot).  Folgende BIOS-Einstellungen haben dabei geholfen.

  • C-State disablen
  • Turbo Modus disablen
C-State HP BIOS

C-State HP BIOS

TurboMode Disable

TurboMode Disable

Das ganze findet man auch direkt auf den Citrix Page:

http://support.citrix.com/article/CTX127395

 

 

Leave a Comment more...

WOL-Infrastruktur einrichten (MagicPacket, Wake on LAN)

by on Jul.06, 2011, under Hardware, Knowledgebase, Wake on LAN

Ich durfte mich kürzlich mit dem Magic WOL auseinandersetzen.

Wie funktioniert WOL eigentlich?

Mittels WOL kann man einen schlafenden Rechner wecken, was für Fernwartungszwecke sehr hilfreich ist.
Der Sender schickt ein sogenannten MagicPacket an die MAC Adresse des Schlafenden.

Auf Seit des „Weckers“ können bei den meisten WOL-Tools die Port- und Subnetzeinstellungen angepasst werden.
Ich verwende in diesem Fall UDP Port 9.  Auf Seit des „Weckers“ können bei den meisten WOL-Tools die Port- und
Subnetzeinstellungen angepasst werden. Ich verwende in diesem Fall UDP Port 9. Zusätzlich kann in diesem Tool das
Subnetz definiert werden, von welchem Magic Packets aus versendet werden können. Dies ist wichtig, wenn man
den „IP Broadcast“ über einen Router hinweg mit ACLs beschränken will, was sicherheitstechnisch durchaus Sinn macht.

WOL Server Einstellungen, Subnetzdefinition

Wie sieht die Konfig auf der Seite des Schläfers aus?

Im BIOS des Clients muss WOL aktiviert werden:

WOL BIOS Settings

WOL BIOS Settings

 

Um Wake on LAN nutzen zu können, müssen sowohl die Hauptplatine als auch die Netzwerkkarte im BIOS APM oder das Advanced Configuration and Power Interface (ACPI) unterstützen. Computer, die ACPI unterstützen, bieten meist mehr Möglichkeiten zur Nutzung von WOL als solche mit dem älteren Standard APM. Allgemein muss die Voraussetzung gegeben sein, dass die Netzwerkkarte über den Standby-Stromzweig des Netzteils weiterhin mit Strom versorgt wird, während der Computer ausgeschaltet ist.

Wenn wir nun das WOL Packet via Tool an den Client senden, dann kann zum Troubleshooten Wireshark hilfreich sein.

Wireshark auf Seite des „Weckers“

Pro im Tool definiertes Subnetz wird ein MagicPacket an die Broadcast Adresse gesendet.

Wireshark Capture Sender

Wireshark Capture Sender

Wireshark Capture Sender 2

Wireshark Capture Sender 2

 

Wireshark auf Seite des Schlafenden

Der Schlafclient erhält in diesem Fall das Broadcast Packet von der WOL Source. Die Kommunikationen zwischen
dem Schlafenden und dem Störefried funktioniert in diesem Fall.

Wireshark Capture Client

Wireshark Capture Client

 

Wireshark Capture Client 2

Wireshark Capture Client 2

Falls sich der Client trotzdem nicht wecken lässt (Magic Packet kommt an), kann es u.a. an folgendem liegen:

  • Fehlerhafte/fehlende BIOS Einstellungen
  • PC / Dockingstation ist vom Strom getrennt (Wandschalter??)
  • Zudem musste bei gewissen Geräten (im Test HP Elitebooks) ein Reg Key gesetzt werden:

Set “HKLM\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\0001!EnablePME” to “1”.
Set “HKLM\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\0001!WakeOn” to “2”.
Set “[HKLM\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\0001!PnPCapabilities” to “32”.

Die Infos habe ich auf der Page des Netzwerkkartenherstellers gefunden.

Wenn das Magic Packet erst gar nicht beim Client ankommt, kann es noch sein, dass ein Router dazwischen das
„IP Broadcasting“ nicht erlaubt. In meinem Fall (CISCO Router) war das „IP directed-broadcasting“ nur für die
ACL 101 erlaubt. Sämtliche im WOL-Tool erlaubten Subnetze mussten noch in der ACL 101 eingetragen werden:

Router Settings

Router Settings

 

Router Settings  ACL 101

Router Settings ACL 101

Zudem können folgende Netzwerk-Devices stören:

  • ungeschirmte Kabel
  • RJ45 Splitter/Combiner
Leave a Comment more...

Swisscom Mobile Unlimited Data Manager – Ethernet oder 3G

by on Aug.11, 2009, under Hardware, Knowledgebase, Kommunikation, Windows XP

Der Swisscom Mobile Unlimited Stick ist recht praktisch für den Internet everywhere access. Bei manchen Installation kommt es jedoch vor, dass der Mobile Unlimited Manager nur Ethernet oder 3G Verbindungen zulässt. Das Clue liegt darin, dass UDM immer versucht, die günstigste Variante auszuwählen und geht davon aus, dass wenn mit dem Netzwerkkabel verbunden wird, auch eine Internet-Verbinung besteht.

Dies kann man umgehen, indem man unter der Netzwerksteuerung die Bindungen “Sesam” und “Wt-engine” entfernt. Somit erkennt der UDM nicht mehr, ob ein Kabel eingesteckt ist.

Leave a Comment more...

Blogroll

A few highly recommended websites...