5ain7 ga11 . CH || i7-l3ak5. CH || g07r007.CH

Archive for May, 2013

Inter-VLAN Trunking zwischen einem Cisco 3750 und HP ProCurve 2910al

by on May.16, 2013, under Cisco, H3c Switches, Hardware, Kommunikation, Networking, ProCurve, Router, Switches

Ich stand von der Aufgabe, einen Layer 3 HP ProCurve 2910al mit einem Cisco 3750 (ebenfalls Layer 3) Switch mittels VLAN-Trunking zu koppeln. Da der Cisco Switch nur noch als “ACCESS-Switch gebraucht wurde” musste ich ihn zuerst mit

<no ip Routing> zu einem Layer 2 Switch degradieren.

Der DOT1Q Trunk war schnell erstellt und die Kommunikation der VLANs untereinander funktionierte fast einwandfrei. Das einzige Problem war, dass die MGMT IPs im VLAN1 einander nicht pingen konnten.

 

ProCurvenormal

ProCurvenormal

Bei einem HP ProCurve Switch sieht ein Trunk Port normalerweise so aus:

In diesem Fall hängt am Port 3 und Port 6 ein weiterer HP ProCurve Switch. Die Kommunikation der nativen MGMT IPs funktioniert in diesem Fall, da der am anderen Ende des Trunk stehende Switch ebenfalls das native VLAN1 hat.

Wenn jedoch am anderen Ende des Schlauches ein Cisco Switch steht, der zwar ebenfalls das VLAN1 als natives VLAN hat, dann funktioniert zwar die Inter-VLAN Kommunikation, aber die MGMT IPs sehen einander nicht….komisch eigentlich…den

<sh cdp neighbors> auf dem HP Switch gibt folgenden Output:

cdp

Der gleiche Befehl auf dem Cisco Switch zeigt keinen Partner an.

Die Lösung lag wie immer in einem kleinen Detail. Der Uplink Port durfte auf dem MGMT VLAN nicht TAGGED sein, sondern UNTAGGED. 1 Klick und die Kommunikation war gewährleistet. Die restlichen VLANs, welche über den Port weitergegeben werden sollen müssen auf TAGGED belassen werden.

untagged

untagged

 

Sample Konfig HP ProCurve (Port 6 ist Trunk Port):

vlan 1
name “Netzwerk-Komponenten”
untagged 6 (uplink port)
ip address x.x.x.x x.x.x.x
exit
vlan XXX
name “TESTVLAN”
ip address x.x.x.x x.x.x.x
tagged 6

Sample Konfig Cisco (Port Gig1/0/2 ist Trunk Port):

interface GigabitEthernet1/0/2
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
mls qos trust dscp
spanning-tree portfast trunk

interface Vlan1
description Netzwerk-Komponenten
ip address x.x.x.x x.x.x.x
no ip route-cache
!

 

und so klappts auch mit dem Nachbar!!

 

 

Leave a Comment more...

JRNL_WRAP_ERROR auf 2008 Domänen Controller / AD Replikation OK, File Replikation NOK

by on May.06, 2013, under Knowledgebase, Server-Plattformen, Windows 2003 Server

Ich hatte folgende Meldung auf einem von zwei DCs. 

The File Replication Service has detected that the replica set “DOMAIN SYSTEM VOLUME (SYSVOL SHARE)” is in JRNL_WRAP_ERROR.

Replica set name is : “DOMAIN SYSTEM VOLUME (SYSVOL SHARE)”
Replica root path is : “c:\sysvol\domain”
Replica root volume is : “\\.\C:”
A Replica set hits JRNL_WRAP_ERROR when the record that it is trying to read from the NTFS USN journal is not found. This can occur because of one of the following reasons.

 Die Replikation vom AD aus ging grundsätzlich, die Filereplikation fuktioniert jedoch nicht.

 Journal Wrap kann mit folgenden Schritten recovered werden:

HKEY_LOCAL_MACHINE.
“System\CurrentControlSet\Services\NtFrs\Parameters”
“Enable Journal Wrap Automatic Restore”
Wert auf 1 setzen.

Wenn es den Wert nicht gibt, den DWORD erstellen. Anschliessen den NTFRS Dienst neu starten.

Im Eventlog unter sollte danach die ID 13560 erscheinen => alles wieder OK.

Leave a Comment more...

Blogroll

A few highly recommended websites...